Problemi geolocalizzazione timbatura

Verifica per quali motivi una timbratura potrebbe essere fuori area.

Lara Egil
Scritto da Lara EgilUltimo aggiornamento 8 mesi fa

Premessa:

Menu portale web Geobadge > Supporto e guida > Privacy > Specifica tecnica.

Geobadge tratta la funzione di geolocalizzazione in modalità GDPR compliance.
L’app può accedere alla posizione della persona (in seguito al login) solo durante l’invio delle timbrature. In quel momento, solo nello smartphone dell’utente, viene effettuato un confronto tra la posizione geolocalizzata del lavoratore e la posizione del luogo configurata nel portale web (client web) da un utente amministratore.

Questa verifica serve solo per determinare se l’utente è nella zona corretta o meno, la posizione non viene salvata in alcun database e non viene inviata ad alcun server.
L’utente può utilizzare l’app anche non concedendo i permessi GPS, non è bloccante e in questo caso il client web non potrà verificare se la timbratura è in area.
Per maggiori informazioni consultare la specifica tecnica di Geobadge.

Problemi:

  1. Il lavoratore, nonostante si trovi nel luogo di lavoro prestabilito, risulta fuori area.

  2. La geolocalizzazione della timbratura non viene sempre rilevata.

Causa:

  1. Il luogo di lavoro creato nel portale web Geobadge potrebbe non essere corretto oppure, al momento della timbratura, non c’è un buon segnale GPS (questo potrebbe accadere specialmente in caso di timbratura in luoghi chiusi oppure in caso di mal tempo).

  2. La validazione della posizione geografica della timbratura è stata impostata come ‘Attiva se disponibile’.

Soluzioni:

Premessa: verificare che la persona abbia acceso il GPS e abbia dato l’autorizzazione alla app.

Android

iOS

Nel caso in cui la persona abbia problemi di timbratura fuori area, la prima cosa da controllare è la correttezza del luogo di lavoro impostato in Geobadge.
Per verificare, fare l’accesso (come Amministratore) al portale Geobadge:

  • Anagrafiche > Luoghi > selezionare il luogo interessato > Modifica.

    Cliccare la sezione Posizione geografica > Imposta con mappa.

    • E’ importante che il pin sulla mappa sia posizionato correttamente; se così non fosse trascinarlo fino alla posizione corretta.

    • Verificare il raggio d’area impostato: se si trattasse di un luogo molto ampio, aumentare il raggio di validità.

Se il luogo di lavoro fosse corretto, probabilmente il problema è dovuto ad una scarsa copertura GPS.
In questo caso il nostro consiglio è quello di chiedere al lavoratore di aspettare circa 10/15 secondi (dopo aver eseguito l’accesso alla app) prima di timbrare: così facendo il GPS del telefono avrà tempo per rilevare in modo più accurato la posizione della persona.

Il fatto che la geolocalizzazione della timbratura non sia sempre presente, dipende dalla configurazione che è stata impostata sul luogo di lavoro.
La validazione della posizione geografica della timbratura si imposta in

Anagrafiche > Luoghi > selezionare il luogo interessato > Posizione geografica > Validazione posizione geografica timbratura.

Questa può essere di 3 tipi:

  • Non attiva: indipendentemente dal fatto che la persona abbia o meno (nel momento della timbratura)  il GPS del telefono attivo, la timbratura non sarà localizzata e non avrà alcun dettaglio di tipo ‘In area’ o ‘Fuori area’.

    • Attiva se disponibile: se la persona (nel momento della timbratura) ha il GPS attivo, la timbratura sarà localizzata e avrà il dettaglio ‘In area’ o ‘Fuori area’; in caso contrario, sarà presente solo l’orario della timbratura.

    • Obbligatoria: la persona (nel momento della timbratura) deve avere il GPS attivo; in caso contrario la app non permetterà la timbratura.

Ricordiamo che, con la validazione geografica della timbratura, ai sensi della normativa privacy, è necessaria la redazione e la consegna dell’informativa ai dipendenti da parte del Titolare del trattamento (e quindi della vostra azienda).

Nel portale Hr.geobadge.com

Supporto e guida > Privacy > Modello documento privacy.

è disponibile per i clienti il modello di informativa fornito come esempio e aiuto per facilitare gli adempimenti in materia di protezione dei dati personali.

Questo articolo ha risposto alla tua domanda?